Reminders and Send Later failures
Incident Report for Yesware, Inc
Resolved
Reminders scheduled for the downtime between April 11 and today have now been pushed, meaning this incident is now fully resolved.

Please do not hesitate to let us know if there are any questions (Support@Yesware.com) and have a nice remainder of the week.
Posted Apr 21, 2020 - 21:26 EDT
Update
All Send Later emails scheduled to send during the downtime (those in which the underlying Draft was not deleted during the downtime) have now been sent.

Reminders scheduled for the downtime will now be processed, with the expectation that all such Reminders will be sent by EOD tomorrow (April 22nd). This is the lone remaining item and all other functionality is now fully available.

If there are any questions, please do not hesitate to reach out to us at Support@Yesware.com.
Posted Apr 21, 2020 - 18:15 EDT
Monitoring
Reminders and Send Later emails may now be scheduled again for users on the latest version of the Yesware extension- extensions will update automatically over the next several hours, but if you would like to manually update your extension at this time you may do so by navigating to chrome://extensions/ > selecting "Developer Mode" (in the upper-right hand corner) > selecting the "Update" button > relaunching GMail.

Send Later emails scheduled during the downtime are now being processed and these emails will be sent over the next few hours (those in which the underlying Draft has not been deleted- as mentioned previously, if the underlying Draft was deleted the Send Later email will not be sent).

Reminders from the downtime will be processed after the completion of the Send Later emails, with the expectation that all Reminders from the downtime will be sent by EOD tomorrow (April 22nd).

Once again, we apologize for the inconvenience this issue caused. If there are any questions and/or comments, please do not hesitate to reach out to us at Support@Yesware.com.
Posted Apr 21, 2020 - 17:59 EDT
Update
Yesware is finalizing a fix and estimates that the issue will be resolved tomorrow (April 21st, 2020). Once the fix has been implemented, all queued Reminders and Send Later emails from the down period will send. To that end, if there are any Send Later emails that you would not like to be sent once the issue has been resolved, please navigate to your Drafts folder and delete the email at this time (doing so will prevent Yesware from being able to find, and send, the email later).

If there are any questions, please do not hesitate to reach out to us at Support@Yesware.com.
Posted Apr 20, 2020 - 13:10 EDT
Update
Yesware continues to work on implementing the fix for this issue, and expects to be live with said fix by mid-week next week.

Please do not hesitate to let us know (Support@Yesware.com) if there are any questions in the meantime.
Posted Apr 17, 2020 - 17:09 EDT
Identified
Yesware has identified the cause of the Reminders and Send Later issue, and is working on a fix.

We will provide an update when that fix has been implemented and ask that you not hesitate to reach out to us at Support@Yesware.com if there are any questions in the meantime. Once again, our apologies for the inconvenience.
Posted Apr 14, 2020 - 15:49 EDT
Investigating
Yesware is investigating reports of missed Reminders and failed Send Later emails starting Saturday, April 11th.

This is being treated as a top priority and updates will be provided on this page as they become available. We apologize for the inconvenience and ask that you not hesitate to reach out to us at Support@Yesware.com if there are any questions.
Posted Apr 13, 2020 - 18:00 EDT
This incident affected: Send Later and Reminders.