Delays with sending emails via Campaigns and Mail Merge
Incident Report for Yesware, Inc
Resolved
The Mail Merge and Campaigns features are working as expected now.
Posted Sep 20, 2018 - 15:44 EDT
Investigating
We're currently investigating reports of delays with Campaign and Mail Merges emails. Our team is looking into this issue with urgency. Updates to follow.
Posted Sep 20, 2018 - 14:12 EDT
This incident affected: Mail Merge and Campaigns.