Some customers are unable to access and/or manage their Campaigns and the Todo cards on the Touchpoints sidebar
Incident Report for Yesware, Inc
Resolved
The majority of customers using Touchpoints should be back up and running now with only a few customers still affected by an ongoing problem. Our team is working on a fix which should resolve the Touchpoints issue for all users tomorrow.
Posted Jan 22, 2018 - 17:34 EST
Investigating
We've heard reports that some customers are unable to access and/or manage their Campaigns and the Todo cards on the Touchpoints sidebar. Our team is looking into the issue with urgency. Updates to follow.
Posted Jan 22, 2018 - 15:54 EST