Touchpoints Campaigns are not accessible for some users
Incident Report for Yesware, Inc
Resolved
This issue has been resolved and all Enterprise users should now be able to use the Touchpoints feature.
Posted May 09, 2018 - 14:23 EDT
Investigating
We are currently investigating reports that our Touchpoints Campaign feature is not available for some users. Our Engineering team is looking into the issue with urgency.
Posted May 09, 2018 - 11:40 EDT